GPS/Magellan/Karttojen tekeminen

KurapyöräWiki
Loikkaa: valikkoon, hakuun

Yhteenveto[muokkaa]

Tämä sivu käsittelee omien karttojen tekemistä Magellan GPS-laitteisiin. Tässä esitettyjä ohjeita voi hyödyntää Magellan Meridian- ja eXplorist-sarjojen laitteiden kanssa ja luultavasti ne ainakin osin soveltuvat myös Triton-sarjan laitteille. Karttoja voi tehdä lähes mistä tahansa lähtöaineistosta ja tässä on pyritty käsittelelmään yleisimmät lähtö tilanteet.

On varsin toivottavaa, että muutikin asiasta innostuneet täydentävät tätä osiota, aina kun törmäävät uusiin ominaisuuksiin tai mahdollisuuksiin aiheeseen liittyen. Lisäksi tämän artikkelin aloittajana minun on pakko todeta, että olen tällä hetkellä erittäin kiireinen ja pyrin pitämään ohjeet varsiin tiiviinä ja toivon, että lukijat malttavat myös hyödyntää tässä artikkelissa mainittuja käyttöohjeita. Terveisin Mika TA-91

Huom! automaatisten reititysominaisuuksien ei ole mahdollista omatekoisissa kartoissa (tai ainakaan tämän kirjoittajalla ei ole tietoa tälläisestä mahdollisuudesta).

Tekijänoikeuksista[muokkaa]

On hyvä huomioida, että suurelta osin kartat ovat tekijänoikeuksien alaista materiaalia, joten kartttoja on syytä tehdä vain omaan käyttöön ja omassa käytössäkin huomioida aineiston käyttöön liittyvat mahdolliset rajoitukset.

Mistä aineistoista karttoja voi tehdä[muokkaa]

  • Garminin kartat
  • GPS reitit, jäljet ja pisteet
  • Erilaisten digitaalisten karttojen materiaali: reitit, jäljet ja pisteet
  • Skannattujen paperikarttojen päälle piirretyt merkit (viivoja, alueita tai pisteitä, jotka kuvaavat kartan elementtejä)
  • Skannatuista kartoista erilaisilla digitoimisohjelmistoilla tehdyistä vektoriaineistoista

Tarvittavat ohjelmistot ja manuaalit[muokkaa]

Ohjelmistot[muokkaa]

Tässä mainitttujen ohjelmistojen lisäksi on käyttäjällä useimmiten oltava vähintäänkin yksi Magellan MapSend (Streets & Destination tai DirectRoute tai Topo) ohjelmisto käytössään, tosin tuon kartaston alueella ei juurikaan ole väliä. Huom! osa taiminnallisuuksista toimivat hiukan erilaisesti eri MapSend ohjemistoilla.

Huomioitavaa on, että erilaisten muunnosohjelmistojen käyttäminen saattaa olla tarpeellista riippuen mitä lähtöaineistoa on käytettävissä.

Manuaalit[muokkaa]

Karttojen tekemistä ja karttoihin liittyviä toiminnallisuuksia käsitellään varsin laajasti seuraavilla sivuistoilla: http://www.msh-tools.com ja http://www.msh-tools.com/addmagmap/, joilta kannattaa ladata/tutustua ainakin seuraaviin materiaaleihin:

AddMagMap[muokkaa]

AddMagMap on ainoita Magellania varten tehtyjä ohjelmistoja, jolla voidaan kohtuullisen helposti tehdä omia karttoja, joita voidaan helposti siirtää Magellanin GPS-laitteelle. Kartat pitävät sisällään samat haku, lajittelu ja esitys toiminnot kuin muutkin MapSend ohjelmistoilta siirretyt kartat.

Huomioitavaa käytettäessä AddMagMap ohjelmistoa[muokkaa]

Eri MapSend ohjelmistot[muokkaa]

Kaikki MapSend ohjelmistot eivät toimi täysin samoin johtuen niiden erilaisista määrittely tiedostoista (lähinnä .ini ja .cfg tiedostoista) jne., joten on hyvä huomioida seuraavia asioita:

MapSend Streets & Destinations Suomi[muokkaa]
  • Toimii muutomia puutteita lukuunottamatta kohtuullisesti.
  • Viivat-muotoisessa aineistossa ei ongelmia, mutta alue- ja pisteaineistojen kanssa siirto GPS-laitteeseen aiheuttaa ongelmia (tutkin tätä lisää ja palaan tähän myöhemmin, jos löydän ratkaisun)
    Pienoiskuvan luominen epäonnistui: Esikatselukuvaa ei voitu tallentaa kohteeseen
  • Ensimmäistä kertaa MS S&D Suomea käytettäessä AddMagMapin kanssa saat seuraavan virheilmoituksen (kuva ohessa), tosin tuo virheilmoitus ei ole suuri ongelma, joudut vain itse manuaalisesti luomaan yhden uuden kansion, eli MS S&D Suomi asunnus polun "MAP"-kansioon luot uuden kansion, jonka nimi on "BackUp", niin tuo virhe poistuu.
  • Itse MS S&D Suomi ohjelmassa hakutoiminnot eivät toimi itsetehdyillä kartoilla, mutta itse GPS-laitteessa haut toimivat normaalisti myös itsetehdyillä kartoilla.
  • Itse käytän tätä kartastoa pohjana, jos teen karttaa Suomen alueelta, koska silloin kartalla ovat näkyvissä myös MS S&D Suomen perusaineisto.
MapSend DirectRoute Europe[muokkaa]
  • Toimii muutomia puutteita lukuunottamatta kohtuullisesti.
  • Viiva- ja alue-muotoisessa aineistossa ei ongelmia pitäisi olla, mutta pisteaineistoa ei voi käyttää.
  • Itse MS DR ohjelmassa hakutoiminnot eivät toimi itsetehdyillä kartoilla, vaan haku joka kohdistuu itsetehtyihin karttoihin aiheuttavat ohjelman kaatumisen, mutta itse GPS-laitteessa haut toimivat normaalisti myös itsetehdyillä kartoilla.
MapSend Topo USA[muokkaa]
  • Toimii hyvin AddMagMap ohjelmiston kanssa
  • Ainoa puute ettei pisteitä voi käyttää osana omitekemiä karttoja
  • Itse käytän tätä kartastoa pohjanan, jos teen karttaa alueelle, josta sellaista ei ole lainkaan olemassa johtuen toiminnan ongelmattomuudesta.
MapSend WorldWide Basemap[muokkaa]
  • Ei toimi AddMagMap ohjelmiston kanssa
MapSend BluChart[muokkaa]
  • Eivät toimi AddMagMap ohjelmiston kanssa, huomaa kuitenkin, että vesistökarttoja voi tehdä myös muilla MapSend ohjelmistoilla.
Magellan MobileMapperOffice[muokkaa]
  • Ei toimi AddMagMap ohjelmiston kanssa

Mistä kartat muodostuvat AddMagMap ohjelmistossa[muokkaa]

AddMagMapo siis hyödyntää jo olemassa olevien Magellan MadSend tuotteiden rakennetta ja lisää niissä jo olevaan materiaaliin uusia elementtejä. Nuo elementit voivat olla viivoista tai monikulmioista koostuvia esimerkiksi teitä, jokia, polkuja, järviä, puistoja jne. Lisäksi osassa ohjelmistoista voidaan käyttää myös pisteitä, mutta niiden käyttötarve on yleensä vähäistä, koska ne yleensä korvataan Point-Of-Interest (POI) pisteillä, jolloin niihin voi liittää paljon muitakin määreitä, kuten esim. puhelinnumeron jne. POI-pisteistä löytyy lisätietoa tuolta: http://www.msh-tools.com/pois.html

Kartan elementtien osalta siis käytetään jo olemassa olevaa rakennetta ja oikeastaan ohjelmassa vain määritellään miten kartalle lisättävät elementit näkyvät PC:llä ja GPS:llä lisäämällä jokainen elementti halutuun ryhmään halutulle tasolle (esim. moottoritie tai polku). Taso jolle elementti lisätään määrittelee suoraan missä zoomausvaiheessa elementti GPS:n näytöllä näkyy. Tämän lisäksi tätä kohtaa voidaan säätää normaalisti itse GPS-laitteessa valitsemalla "kartta-asetukset"-valikosta "yksityiskohdat" halutulle tasolle. Alla esimerkki, jossa käytetty Magellan eXplorist 500 GPS laitteen ryhmiä (Groups) ja tasoja (Layer), kun kartta on ladattu MapSend Topo3D USA:lta:

Pienoiskuvan luominen epäonnistui: Esikatselukuvaa ei voitu tallentaa kohteeseen


Nämä ryhmät (Groups) ja tasot (Layer) määritellään AddMagMapissa suoraan jokaiselle lisättävälle elementille (tai elementti joukolle) seuraavassa käyttöliittymässä:

Pienoiskuvan luominen epäonnistui: Esikatselukuvaa ei voitu tallentaa kohteeseen

Se kuinka elementin halutaan näkyvän GPS-laitteessa määritellään "Layer"-valikossa, jossa kaikki käytettävissä olevat ryhmät ja tasot näkyvät, joista yksi valitaan laittamalla rasti haluttuun ruutuun. Koska näkymä PC:llä vaihtelee käytettävästä MapSend ohjelmasta riippuen valitaan vielä erikseen haluttu piirtotapa "Drawn Type", josta löytyy laja valikoima erilaisia piirtotapoja, jotka ei siis vaikuta näkymään GPS-laitteella.

Karttojen luominen eri aineistoista[muokkaa]

Garmin kartat[muokkaa]

Omatekoisten karttojen tekeminen Garminille tehdyistä kartoista on kohtuullisen helppoa johtuen siitä, että ne on tarkoitettu GPS käyttöön ja niitä löytyy (ilmaiseksi) kohtuullisen paljon, koska formaatti on ollut esim. Magellania avoimempi ja käyttäjiä on (ilmeisesti) enemmän. Jotta karttojen siirtämien olisi mahdollisimman helppoa on hyvä ymmärtää miten Garminin ja Magellanin kartat eroavat toisistaan:

  • Garminin kartoissa elementit eivät ole itsenäisiä, vaan ne ovat aina osa erillisiä kerroksia, jotka näytetään eri zoomaustarkkuuksilla. Se millä tarkkuudella mikäkin kerros näytetään riippuu käyttäjän valitsemista asetuksia. Tämä tarkoittaa, että sama elementti saattaa olla osana useampaa eri kerrosta esim. moottoritie.
  • Magellanissa jokainen elementti kuuluu omaan ryhmäänsä ja tasoonsa, jolloin elementti esiintyy aineistossa vain kerran ja sen ominaisuudet määrittyvät ryhmän/tason mukaan johon se kuuluu.
  • Yllä olevasta johtuen suora kopiointi ei ole mahdollista vaan jokaisen elementin osalta on päätettävä miltä Garminin kerrokselta elementti kopioidaan, koska jos se kopiodaan kaikilta saatavissa olevilta kerroksilta on mahdollista, että lopullisessa Magellan kartassa onkin samalla kohtaa yhden tien asemasta useampi tie.


Garminin karttoja löytyy kahdessa eri formaatissa:

  • Virallisena *.img tiedostoina, joka samasta päätteestä huolimatta ei yhteensopiva Magellanin tuotteiden kanssa
  • Omatekoisten karttojen tekemistä varten kehitettynä *.mp tiedostona (Polish Map Format, PMF)


Karttojen tekeminen Garmin materiaalista[muokkaa]

Käytän tässä esimerkkinä http://gps-maps.info/en/maps/download sivuilta löytyvää Garmin karttamateriaalia (cz_map.zip ja sieltä kartta 42001002).

Ensimmäinen vaihe karttojen tekemisessä on saada lähtöaineisto AddMagMap ohjemiston ymmätämään muotoon.

  1. Garminin kartta (*.img) käännetään ensin Polish Map Formatiin käyttäen GPSMapEdit ohjelmistoa (onnistuu muistaakseni myös ilmaisversiolla).
    1. Avaa Garmin karttatiedosto ja sen jälkeen tallenna se "File" valikosta löytyvällä "Save Map As..." komennolla (Huom! muista vaihtaa tallennusvaiheessa tiedostomuoto "Save as type" Polish Formaattiin (listan ensimmäinen)).
    2. Huom! Mikäli Garminin kartta on jo PMF muodossa (*.mp) ei tätä käännöstä tarvitse tehdä.
  2. Yllä saatu PMF tiedosto käännetään ESRI tiedostoksi (*.shp, joka on yksi yleisimpiä kaupallisia paikkatietoformaatteja).
    1. Tämä onnistuu AddMagMap ohjelman omalla työkalulla (Ptext2shp), joka löytyy "Tools" valikosta.
      Pienoiskuvan luominen epäonnistui: Esikatselukuvaa ei voitu tallentaa kohteeseen
    2. Työkalu luo automaattisesti kaikkille kolmelle muototyypille (viiva (L=line), alue (A=area) ja piste (P=point))omat *.shp tiedostonsa. Miukäli jollekkin muototyypeistä ei ole tarvetta voi kyseisen muototyypin jättää poin poistamalla rastin kyseisen muototyypin edestä.
    3. Tiedostot voi nimetä oman halunsa mukaan, mutta laittamalla rastin kohtaan "ESRI shp file prefix" muodostaa työkalu nimet eri tiedostotyypeille automaattisesti käyttämällä alkuperäistä *.shp tiedoston nimeä lisäämällä ain muototyypiin määreen (L, A tai P).


Yllä luodut *.shp tiedostot koostuvat seuraavista komponenteistä:

  1. Jo yllä mainitun mukaisesti viivoja, alueita tai pisteitä.
  2. Jokainen L, A ja P tiedostoista sisältää alkuperäisen kartta-aineiston mukaisesti kartta elementtejä, jotka Garminin määreiden mukaisesti kuuluvat eri kerroksiin, jolloin sama elementti voi olla tiedostossa useampaan kertaan.
  3. Lisäksi tiedostossa on kolme määrettä jokaiselle elementille: LABEL (= nimi, numero, tunnus tms.), TYPE (= tie, moottoritie, polku tms.), and LAYER (= Garminin kartan kerroksen numero (elementti voi siis kuulua useampaan kerrokseen)).


Nyt meillä on valmiina tarvittava aineisto, jonka seuraavaksi upotamme osaksi olemassa olevaa MapSend ohjelmistoa AddMagMap ohjelmiston avulla seuraavissa vaiheissa (vaiheiden tarkempi kuvaus käyttöliittymäkuvan jälkeen). Huom! kaikkien MapSend ohjelmistojen on oltava pois päältä:

  1. Valitaan käytettävä MapSend ohjelma (jos useampia valittuna)
  2. Annetaan oma tekemällä kertalle nimi (tai valitan jo aiemmin luoto kartta)
  3. Valitaan mistä aineistosta kartta tehdään (yllä luodut tiedostot)
  4. Valitaan mitä elementtejä kyseisestä tiedostosta tuodaan (tämä vaihe vaihtelee aineisto mukaan)
  5. Valitaan mihin Magellanin ryhmään (Group) ja tasoon (Layer) elementti sijoitetaan
  6. Valitaan miten elementti näytetään PC:llä (MapSend ohjelmassa)


Pienoiskuvan luominen epäonnistui: Esikatselukuvaa ei voitu tallentaa kohteeseen


(1) Valitse alasvetovalikosta käytettävä MapSend ohjelma. AddMagMap etsii automaattisesti asennetut MapSend ohjelmistot, toiminnon helpottamiseksi kannattaa kaikki MapSend tuotteet asentaa samaan tiedosto polkuun, esim. programs/Magellan/. Mikäli haluamaasi MapSend ohjelmistoa ei löydy voi sitä hakea myös manuaalisesti “Browse” painikkeella (kuvake alasvetovalikon oikealla puolella). Joitain MapSend tuotteita AddMagMap ei löydä edes haun avulla, jolloin niitä ei voi myöskään käyttää.

Pienoiskuvan luominen epäonnistui: Esikatselukuvaa ei voitu tallentaa kohteeseen

(2) Annetaan oma tekemällä kertalle nimi (tai valitan jo aiemmin luotu kartta). Edellä valitulle MapSend ohjelmalle jo ennestään tehdyt kartat näkyvät punaisella neliöllä alasvetovalikossa. Uusi ei vielä tallennettu kartta näkyy vihreällä neliöllä . Tässä alasvetovalikossa näkyvät ainoastaan itse tehdyt kartat, jotka voidaan myös MapSend ohjelmasta poistaa ilman että sillä on vaikutusta alkuperäiseen MapSend ohjelmaan. Uusi kartta aloitetaan ja nimetään painamalla alasvetovalikon oikealla puolella olevaa kuvaketta.

Pienoiskuvan luominen epäonnistui: Esikatselukuvaa ei voitu tallentaa kohteeseen
(2.1) Uuden kartan nimemeämisen lisäksi, joka tapahtuu alla olevassa valikossa, joka aukeaa alasvetovalikon oikealta puolelta, on huomioita uuden kartan alue, jolla annetaan nimeämisen yhteydessä kordinaatit. Mikäli kordinaatteja ei anneta olettaa ohjelmisto, että uusi kartta kattaa koko maapallon